Is this the correct Forum for WattOS

I arrived here because I downloaded WattOS 10 and I am looking for some help. Have I come to the right place? Also is ViaOS taking over from WattOS and will it still run on old hardware ie Pentium 4 256Mb ram Nvideo GeForce 488 Go GPU?

Many thanks Fozzie

@FozzieBear hiya and welcome to the forum firstly…

  1. yes we can still help with WattOS
  2. viaOS is the new name for WattOS
  3. Specs to be released very soon… Alpha build is almost done… you can see a sneak preview here… https://forums.viaos.io/t/dev-update-3-1-2020/50
    32bit is to be confirmed as it’s getting increasingly harder to support this now with linux.

Hope that helps for the moment. I will create a new thread for WattOS questions shortly.

Hi FozzieBear, what do you need help with?

Hi Leenie,
I am having problems installing WattOS 10 on an old laptop. The live CD runs but the majority of the text is missing from folders and menu items just like this post https://askubuntu.com/questions/582980/missing-letters-in-menus-and-folder-names except I have an Nvidia GeForce 488 Go GPU and not an intel one.
I want to install WattOS to the hard drive but cannot see any of the prompts and menus. I’ve even installed it as a virtual machine on another PC so I can follow the menu step by step but even thats impossible. I’m not sure if its a similar graphics acceleration issue or just that there are no inbuilt drivers for the GeForce 488 Go in the live CD. I was wondering if I could slipstream them into the iso or install them at boot time???
As an aside I have also tried to install Bohdi Linux on the same laptop and have no issue with the font except when I try to install it from the boot menu rather than from within the running LiveCD OS.
Any suggestions would be appreciated.
Fozzie

Thats an old 4MX card… i think that may be a case of limited driver support. It falls under the NV10 (Celcius) family - (Added support for hardware TCL and a lot of other 3d features, enabling fully accelerated OpenGL 1.2) looking at linux drivers …
@Leenie might know if there is a workaround for this 4 MX … if not … then its over to @biff when he gets some free time

Thanks Cherion, I wondered if it was a driver issue. I assume this would also happen when using the “Safe Graphics” boot option in the boot menu? I will await a reply from Leenie.

Fozzie

Hi @FozzieBear no worries. Sorry i can’t help further on this… this is more leenie’s or biff’s territory side of things.
Many thanks for the question though and do bear (gah… pun!!!) with us :rofl:

@FozzieBear There is always oibaf drivers. It’s worth a try. Scroll down to “Adding this PPA to your system” on this page: https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers, and follow the directions. It is command line, hope you are comfortable with that.
To uninstall if it does not work: === Revert to original drivers ===
To revert to standard Ubuntu drivers type the following in a prompt shell:
$ sudo apt-get install ppa-purge
$ sudo ppa-purge ppa:oibaf/graphics-drivers
Best of luck and let me know how it went.

1 Like

Glad you’re here @Leenie ! many thanks for helping Fozzie with that :slight_smile:

Thanks Leenie,
Problem is I cannot see any of the menus and even terminal is the same so can’t navigate round the system. Is it possible to install drivers at boot?
Fozzie

Can you give more information on the card? I went to Nvidia.com to look it up. Not there. Need more information.

Hi Leenie, This is a laptop so GPU is integrated on motherboard. All the information I have is from Device Manager in XP. Heres the information I have found. https://www.techpowerup.com/gpu-specs/geforce4-488-go.c1557
As an aside on the grub boot menu there is a Safe Graphics option. iIs this the equivalent of XP’s 600 x 480 mode? Should this work with all graphics cards. The thing is when I select this option there doesnt appear to be any difference in the OS resolution when booted. Is this something called NOMODESET? I am a linux newbie and dont really understand this but is this an option that can be set at boot. I have tried hitting the Tab key which allows editing of the menu but nothing seems to happen.
Fozzie

Can you open a terminal with Ctrl Alt T? Press keys all 3 keys at the same time to get it to open. Type sudo synaptic. It will ask for your password and then you press enter on keyboard. When synaptic window opens, click on settings at top. Then, under settings click on repositories in dropdown. When repositories window opens, click on additional drivers tab at top. It will show a list of drivers available.
Can you make a list of the drivers? We need to figure out which driver to use.

Hi Leenie, I really appreciate you trying to help me but thought I better upload some photos of the screen to show you what I am up against.Menus
As you can see from picture the majority of the font is missing so making it alsmost impossible especially with a new OS to find or do anything.
Similarly the next photo is Terminal which I was able to launch using your keyboard shortcuts. I have input a string of “a’s” to show what it looks like. As you know terminal is fussy with spaces and correct formatting so again almost impossible. I cant even type out the commands in a text file and copy and paste into terminal as I cant read the prompts.
Terminal
I think I may have to give up on this OS unless there is a way at boot to input flags that affect graphics like you can in Mac. As you can see the boot menu is visibale and readable but the xForceVESA doesn’t appear to make any difference
Boot Options
Its a real shame as this OS appears to fit the bill as far as being very lightweight, modern and fast on very old hardware.
Kind regards
Fozzie

I’ll wait for @Leenie on this… but this almost looks like the disc is corrupt… did you verify the download ?

Yes Disc OK.
However I have now managed to boot into WattOS Live CD using NOMODESET flag, instructions for which I found on a Linux Mint Forum. Text is displaying now but when I followed Leenie’s instructions for additional drivers under Synaptic Package Manager none are listed. Should I try oibaf drivers now? I am able to install WattOS to the hard drive but don’t know if Ill have same problem with video on reboot?

Fozzie

Hi @FozzieBear thanks for verifying the disc was ok and that you have now managed to boot in now…

does this help you ? https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.12/+bug/173095

or maybe this?

Thank you @Cheiron. @FozzieBear, the launchpad bug shows how to correct this problem. Do you know how to edit the xorg.conf file? Open terminal, type whereis xorg.conf to find it. In xorg folder look for xorg.conf, if it does not exist, you can create it and copy the text from Cheiron’s link: https://bugs.launchpad.net/ubuntu/+source/linux-restricted-modules-2.6.12/+bug/173095. Close and save the file. Reboot computer. If you need exact step by step, let me know. I do gui, Cheiron will probably have the command line way.

Thanks Both,
Will try this later as need to get back to erecting fence. Thank you both for your help ill keep you posted.
Fozzie

1 Like

@Leenie i just found the fix… the command line and gui stuff is your speciality :crazy_face: :crazy_face: :crazy_face:

1 Like